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Leadshine reserves the right to make changes without further notice to any products 

herein to improve reliability, function or design. Leadshine does not assume any 

liability arising out of the application or use of any product or circuit described 

herein; neither does it convey any license under its patent rights of others.  

Leadshine’s general policy does not recommend the use of its products in life 

support or aircraft applications wherein a failure or malfunction of the product may 

directly threaten life or injury. According to Leadshine’s terms and conditions of 

sales, the user of Leadshine’s products in life support or aircraft applications 

assumes all risks of such use and indemnifies Leadshine against all damages. 

©2011 by Leadshine Technology, All Rights Reserved 
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Introduction 

ProTuner for ACS806 is a software tool designed to configure and tune the Leadshine digital servo drive ACS806. The user can tune the 

current loop and adjust the position loop parameters in this software. 

Workspace 

  

Menus and Toolbar 

Menus and toolbars are at the top of the workspace. You can click menu bar to view the pull-down menu. The toolbar below the menu 

offers the most frequency used commands. 

 

 

 

 

 

 

 

 

 

Menu Toolbar 

PID Tuning Window 
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Menu Pull Down Toolbar Function Short cut 

File -> Open 
 

Open a file Ctrl + O 

 Save 
 

Save a file - 

 Save As - Save as a file - 

 Close - Close the current file - 

 Exit - Exit from the software Ctrl + X 

Drive -> Connect - Connect to drive Ctrl + N 

 Current Loop 
 

Set current loop parameters Kp and Ki 

and test. 
- 

 Configuration 
 

Set drive properties like I/O logic, 

motor parameters. 
- 

 Download to Drive  Download all data to drive - 

 Reset  Restore factory setting - 

Tools-> Scope 
 

Open the scope and check the 

measured current, position following 

error and motor velocity. 

- 

 Error Log 
 

Check the error log. - 

Help-> User Manual on Web  Hardware manual - 

 Software Manual on Web  Software manual  

 About Leadshine ProTuner  Software information - 
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Using the Software 

Opening a file 

If you want to reload the configuration data from a file in the PC, click on File->Open. The parameters in the software’s workspace will 

be updated. The file name will appear on the up-right of the tile bar. 

 

Save a file 

Click Drive->Save to save data of the current workspace to the file opened. If there is no a file opened, the Save dialog box appears and 

you can type in the file name.  

Save as a file 

Click Drive->Save As to save the data in current workspace to a file and rename it. 

Close 

Click Drive->Close to close the current file. 

Connecting Drive 

 

Connect to Drive window appears at start-up. You can open it by clicking Drive->Connect To Drive any time. Select the right serial 

port and click on the Open button. The software will try to connect to the drive and read the settings. It may take several minutes. Please 

wait. 

! 1

Noti ec 2) The drive has been powered on and the green LED is on.  

Before clicking on the Open button, please make sure: 

) The RS232 cable .has been connected between the drive and the PC’s serial port. 

The motor is unnecessary connecting to the drive if you just want to change the parameters but not tuning. 

!
Caution  

Do not connect or disconnect serial cable when the drive is powered on. The drive’s communication circuit may be 

damaged. 

File Name 
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Current Loop Tuning Window 

  

Red Curve: 

Target Current of Step Test 

Green Curve: 

Actual Current of Step Test 

Click Drive->Current Loop to open the current loop tuning window. It is used to configure current loop parameters according to 

different motor. In the tuning window, the user can adjust the proportional gain, integral gain and test Current. 

Item Description Range 

Proportional Gain 

Increase this parameter to make current rise fast. Proportional Gain 

determines the response of the drive to current setting command. Low 

Proportional Gain provides a stable system (doesn’t oscillate), has low 

stiffness, and large current error, causing poor performances in tracking 

current setting command in each step. Too large Proportional Gain values 

will cause oscillations and unstable systems. 

1 – 65535 

Integral Gain 

Adjust this parameter to reduce the steady error. Integral Gain helps the 

drive to overcome static current errors. A low or zero value for the Integral 

Gain may have current errors at rest. Increasing the Integral Gain can 

reduce the error. If the Integral Gain is too large, the systems may “hunt” 

(oscillate) about the desired position. 

1 – 65535 

I-Test The current amplitude for the step response. 0.5 – 6 A 

Test Button 
Click this button to activate the test. A target curve (red) and an actual 

curve (green) will be displayed on the screen for user analysis. 
- 
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Configurations Window 

  

Digital Scope 

Internal Pulse Generator Settings

Scope Settings 

Parameters 

Click Drive->Configurations to open the configurations window. The user can adjust the position loop PID parameters and check the 

result by clicking the Start button. A build-in Pulse Generator performs trapezoid velocity motion and the Digital Scope displays the 

motor’s actual velocity, current and position following error. You can also set the electrical Gear, encoder resolution, position error limit 

and motor pairs in this window. 

Digital Scope 

Item Description Range 

Current (A) Current axis of the digital scope. Unit: Amp. - 

Velocity (rpm) Velocity axis of the digital scope. Unit: rpm - 

Position Error (p) Axis of Position following error in digital scope. Unit: Pulse - 
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Scope Settings 

Item Description Range 

Velocity 
Actual measured velocity measured by the encoder. Ideally, this 

value should be as close as possible to the commanded velocity. 
- 

Current Actual measured current. Click to display it in the scope. - 

Position Error 
Position following error. The difference between commanded 

position and the actual measured position. 
- 

Trace Time Trace time of the digital scope. 100 – 3000ms 

Internal Pulse Generator Settings 

Item Description Range 

Velocity (rpm) Target velocity of Pulse Generator.  1– 65535 rpm 

Acceleration (r/s^2) Acceleration of Pulse Generator. 1 – 65536 r/s^2 

Interval Interval between the positive and negative move. 1 – 65535 ms 

Distance (s) Move distance of Pulse Generator. 1 – 65536 pulses 

Repeat Times Repeat times. 1– 65535 
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Position Loop Parameters 

Item Description Range 

Kp 

Position Proportional Gain. Proportional Gain determines the response of the system to 

position errors. Low Proportional Gain provides a stable system (doesn’t oscillate), has 

low stiffness, and large position errors under load. Too large Proportional Gain values 

will cause oscillations and unstable systems. 

0 – 65536 

Ki 

Integral Gain. Integral Gain helps the control system overcome static position errors 

caused by friction or loading. The integrator increases the output value as a function of 

the position error summation over time. A low or zero value for the Integral Gain may 

have position errors at rest (that depend on the static or frictional loads and the 

Proportional Gain). Increasing the Integral Gain can reduce these errors. If the Integral 

Gain is too large, the systems may “hunt” (oscillate at low frequency) about the desired 

position. 

0 – 65536 

Kd 

Position Derivative Gain. Derivative Gain provides damping by adjusting the output 

value as a function of the rate of change of error. A low value provides very little 

damping, which may cause overshoot after a step change in position. Large values have 

slower step response but may allow higher Proportional Gain to be used without 

oscillation. 

0 – 65536 

Electrical Gear 

Item Description Range 

Electronic 

Gear 

This parameter includes numerator and denominator. You can scale the pulse 

frequency and calculate the motor speed as follows: 

atorDeno

Numerator

solutionEncoder

FrequenceInputPulse
RPM

min
4)Re(

60)(





  

1/255 – 512/1 

 

 

 

 

 

 

 

 

 

 

 

  7 SW‐ACS806‐R20111215



                                     Software Operational Manual for ACS806 

Other Settings 

Item Description Range 

Encoder 

Resolution 

Encoder Resolution for the Internal Pulse Generator. 

Note: This parameter is only used for the Internal Pulse Generator. It is 4 times of the 

encoder lines. 

400 – 60000 

Position 

Error Limit 

Position Following Error Limit The limit of the difference between commanded 

position and the actual measured position. When position following error exceeds the 

Position Following Error Limit in the drive, the following error protection will be 

activated. 

0 – 65535 

Motor Paris Motor poles divided by 2. Please refer to motor datasheet. 1 – 20 

Input Mode Settings 

 

The user can set the command’s active edge, direction logic, active level of the Enable and Alarm signal, position following error, 

electrical gear and motor pole pairs according the motor and application.  

!
Notice  

The Motor Pole Pairs is very important parameter. .It is 2 for Leadshine’s BLM series motor and 4 for Leadshine’s ACM 

series motor. 

Item Description Range 

Command Type 
Pulse control mode of the drive. PUL/DIR means pulse and direction, 

CW/CCW means clockwise pulse and counter clockwise pulse mode. 
PUL/DIR or CW/CCW

Limit Signal Active Level of the limit sensor input. Active High/low 

Active Edge Setting the triggered edge of pulse command signal. Rising / Falling 

Direction 
Setting Default motor rotate direction. You can change the direction 

via this option. 
Positive / Negative 
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Scope 

Click Tool->Scope to open the scope which is built inside the drive. You can check the actual measured velocity, current and position 

following error in this window. 

 

Item Description Range 

Current (mA) Actual measured current. - 

Velocity (r/min) 
Position following error. The difference between commanded 

position and the actual measured position. 
- 

Position Error (pulse) 
Actual measured velocity measured by the encoder. Ideally, this 

value should be as close as possible to the commanded velocity. 
- 

Start/Sop button Click to turn on/off the scope. - 
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Error Log Window 

Click Tool->Error Log to open the error log window. This window shows both the present status of each error event and their history. 

 

Item Description 

Over Current Protection will be activated when the motor current is over 20A. 

Over Voltage Protection will be activated when the input voltage is over 40+/-1V. 

Low Voltage Protection will be activated when power supply voltage is lower than 18±1.5 VDC. 

Phase Error 
Motor power lines wrong & not connected and encoder or hall sensor feedback signals wrong 

connected will activate this protection.  

Encoder Error 
Protection will be activated when no encoder feedback signals or wrong encoder/hall sensor 

feedback signals connected to drive. 

Position Limit  Protection will be activated when the positive or negative limit input in FL or RL pin is active. 

Following Error 
Protection will be activated when position following error exceeds the Position Following 

Error Limit. 
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Configuring the Drive 

If it is the first time setup, you can follow the steps below to configure the drive.  

1) Set motor related parameters such as motor pole pairs, encoder resolution and position following error. 

2) Tune the current loop parameters according to motor connected. 

3) Tune the position loop parameters for the low speed and high speed performance. 

4) Save the changes to drive’s nonvolatile memory. 

!
Notice  

The motor must be connected to the drive before trying to configure the drive. 

Current Loop Tuning 

The ACS806’s current loop need to be tuned before normal operation in order to get optimize responses with different motors. Otherwise 

the motor will be easily stall or howls when power-up. Below is the tuning process for a 200 Watt motor with 24VDC supply voltage. 

Step 1: Click Drive->Current Loop to open the tuning window. Set I-test 1 and start the tuning with small Kp and “zero” Ki. Here we 

set Kp 4000. 

 

Initial Value 

Kp = 4000 

Ki =1 

 

Step 2: Click the Start button， the plot window will show two curves. The red one is target current and the green one is actual current. 

There is large gap between them in the scope. It indicates that a large Kp needs to be introduced. 
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Step 3: Increase Kp to 8000 and click Test. The distance between target value and actual value is smaller but a higher Kp is still 

needed. 

 

 

 

Step 3: Give Kp 12000, 15000, 21000 and click the Test button, respectively. The green curve is getting more and more close to the 

red curve. Intersection appears when we increase Kp to 21000. It indicates that you need to stop increasing Kp and back off. Our 

purpose is to make the green curve (the actual current) close to the red curve (the target).  

 

 

 

↑ Proportional Gain: 

Kp = 8000 

Ki = 1 

Start Test: 

Proportional Gain = 4000 

Integral Gain = 1 
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↑ Proportional Gain: 

Kp =12000 

Ki = 1 

↑ Proportional Gain: 

Kp =15000 

Ki = 1 

↑ Proportional Gain: 

Kp =21000 

Ki = 1 Intersection 
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Step 4: Now the Kp is relatively good enough. But there is still distance between the green curve and the red curve when we use the 

mouse to zoom in the green curve. So we need to introduce Ki to reduce the distance or steady error at the constant part. It follows the 

same procedure as Kp. High Ki causes big vibration, system lag and makes the performance worse. The following figures show how to 

tune the Ki. 

 

 

 

Zero Integral Gain: 

Kp =21000 

Ki = 1 

↑Integral Gain: 

Kp =21000 

Ki = 200 

Drag a triangle to zoom in 
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Step 5: The current loop tuning is basically finished. You can continue to adjust Kp and Ki for better performance. Now the updated 

Kp and Ki is just stored in the driver’s RAM. They will be lost when we power off the driver. Don’t forget to click Drive->Download 

To Drive to store the changed value to the drive’s nonvolatile EEPROM.  

!
Notice  

You can reduce the Kp if the motor’s noise can not be accepted for the application.  

 

 

 

↑Integral Gain: 

Kp =21000 

Ki = 400 

Save all the changes to the drive’s 

non-violated nonvolatile memory. 

Final Result: 

Kp =19000 

Ki = 600 
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Tuning the Position Loop Parameters 

Click Drive->Configurations to open the tuning window. The following example demonstrates the tuning of the position loop base on a 

400W servo motor with 24VDC input. 

!
Notice  

The motor should be installed to the machine and connected to load before the position loop tuning. 

!
Caution  

Move the load to the middle of the axis and make sure 40000/Encoder Resolution turns of motor shaft will not hit anything. 

Otherwise, please reduce the distance setting in the pulse generator. 

Before tuning the position loop parameters, set pulse generator parameter as the following figure. We select the actual velocity and 

position following error to be displayed in the digital scope. Trace Time affects the display length of the curve. Here we select 1200ms. 

 

Pulse Generator and Scope  

Settings in this Example: 

Velocity = 1200rpm,  

Acceleration = 200r/s^2,  

Distance = 80000Pulse,  

Repeat Times = 1 

Click the Velocity and 

Position Error Curve,  

Trace Time = 1.2s 
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The pulse generator will generate the following command trapezoid velocity profile. It takes 100ms to make the motor to accelerate 

from 0 to 1200 rpm. 

 

0

300
600

1200

900

-300

-600

-900

-1200

Velocity(RPM)

 

Our purpose is to get the highest system stiffness but lower motor noise. The actual measured velocity should be similar as the 

commanded velocity curve. However, sometimes we need to trade off between high stiffness and low motor noise because high 

proportional gain leads to big overshoot and vibration. In this example, we start with small proportional gain then increase it. We will 

stop increasing when the motor noise can not be accepted. The tuning procedure is shown as follows: 

 

Step 1: Set Kp = 1000, Ki = 0, Kp = 1000. The initial value is depending on supply voltage, motor and reflected load inertia. The 

above values may not suitable for your system. Please adjust them according to different symptom as follows: 

 Decrease Kp and Kd if the motor generates big noise. Kp and Kd can be the same at the beginning. 

 Increase Kp and Kd if the drive’s red LED blinks (Protection mode).  

 

Servo Motor

E
n

c
o

d
er

 

Observe the motor noise/vibration when increasing loop gain 

Press the Start button to start the test. The motor shaft will move (40000/Encoder Resolution) turns in two directions. Not long later the 

actual measured velocity and position error curve are displayed in the scope as follows. We see that the position error is large and the 

velocity curve is not very good when comparing to the commanded one. 

 

① Ki =0, Small Kp and Kd ②Kp↑ , Kd↑   ③Small Ki  ④Adjust Kp and Kd 

Tip: Giving an external torque by rotating the motor shaft (or moving the load) manually is good way to check whether the Kp and Kd 

are suitable or not. If it is hard to rotate/move and the motor generates big noise, you should lower down Kp and Kd. If it is easy to 

rotate/move and even the drive goes into protection mode (the red LED blinks), you should increase Kp/Kd. 

Commanded Trapezoid Velocity Curve 
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Step 3: Increase Kp and Kd to maximize the system stiffness or minimize the position error until the motor noise/vibration can not be 

accepted. To activate the noise/vibration, sometimes you need to give a disturbance to the load by either clicking the Start button or 

trying to push/pull the load. In this example, we give Vp 400, 800, 1000 and find that the noise/vibration at Vp=1000 can be accepted. 

So we stop increasing Vp. 

 

Kp = 1000, 

Ki = 0  

Kd = 1000 

Green Curve: 

Actual Measured Velocity. 

Blue Curve: 

Position Following Error. 

Position Error = 233 
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↑Proportional Gain: 

↑Kp = 2000, 

Ki = 0  

↑Kd = 2000 

Position Error = 102 

↑Proportional Gain: 

↑Kp = 3000, 

Ki = 0  

↑Kd = 3000 

Position Error = 66 
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↑Proportional Gain: 

↑Kp = 4000, 

Ki = 0  

↑Kd = 4000 

↑Proportional Gain: 

↑Kp = 5000, 

Ki = 0  

↑Kd = 5000 

Position Error = 50 

Position Error = 41 
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Now the system has been basically tuned. You can continue to increase the Kp and Kd but the motor noise will also be increased 

too. We stop here in this example. In the following step, we give small Ki to “Zero” the position error at constant velocity (The 

velocity curve is straight). However, big noise may be introduced if Ki is too big. 

 

Step 4: Set .Ki = 200 and the position error at constant speed becomes near 0. 

Remember that tuning the servo is to get satisfying performances, getting the best performances of the servo is a time consuming work. 

So if the servo performance can meet your application requirements, then the easier tuning way the better. Just like if the performances of 

the products can meet your application requirements, then the cheaper the better.  

Step 5: Don’t forget to click Drive->Download To Drive to store the changed value to the drive’s nonvolatile EEPROM. 

 

↑Proportional Gain: 

↑Kp = 6000, 

Ki = 0  

↑Kd = 6000 

Position Error = 34 
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Kp = 6000, 

Ki = 0  

Kd = 6000 

Position Error = 8  

When Ki = 0 and the target 

speed has been archived 

Kp = 6000, 

Ki = 400  

Kd = 6000 

Position Error = 0  

When Ki = 400 and the target 

speed has been archived 
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Contact Us 

China Headquarters 

Address: 3/F, Block 2, Nanyou Tianan Industrial Park, Nanshan District Shenzhen, China 

Web: http://www.leadshine.com 

Sales Hot Line: 

Tel: 86-755-2641-7674 (for Asia, Australia, Africa areas) 

    86-755-2640-9254 (for Europe areas) 

    86-755-2641-7617 (for America areas) 

Fax: 86-755-2640-2718 

Email: sales@leadshine.com. 

Technical Support: 

Tel: 86-755-2641-8447, 86-755-2641-8774, 86-755-2641-0546 

Fax: 86-755-2640-2718 

Email: tech@leadshine.com(for All) 

Leadshine U.S.A 

Address: 25 Mauchly, Suite 318 Irvine, California 92618 

Tel: 1-949-608-7270 

Fax: 1-949-608-7298 

Web: http://www.leadshineUSA.com 

Email: sales@leadshineUSA.com and support@leadshineUSA.com. 
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